Equipment failure stops Metro-North train

Report It photo from Jbpagliaro after Metro-North breakdown in Milford, Feb. 27, 2014.

MILFORD, Conn. (WTNH) — Equipment failure brought a Metro-North train to a stop in Milford early Thursday.

The problem happened on the 6:32 train out of New Haven heading to Grand Central.

According to Metro-North, the train was briefly stopped around 6:40 a.m. due to equipment failure on the train itself.

Passengers had to get off the train in Milford, and get on the next arriving train to continue their commute.

One passenger who emailed News 8 via Report it said “We had to get off Milford, go down and under the tracks in 9 degree weather to get on another train. There is only standing room in the aisles left me we still have to make another 6 stops.”

Legislative committees in Hartford and in Washington D.C. will be discussing Metro-North and rail safety in general today.

WTNH NEWS8 provides commenting to allow for constructive discussion on the stories we cover. In order to comment here, you acknowledge you have read and agreed to our Terms of Service. Commenters who violate these terms, including use of vulgar language or racial slurs, will be banned. Please be respectful of the opinions of others. If you see an inappropriate comment, please flag it for our moderators to review. Also, you can now block any inappropriate user by simple selecting the drop down menu on the right of any comment and selection "Block User" from there.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s